nixos-config/users/simon/modules/git.nix

40 lines
790 B
Nix

{ config, ... }:
{
programs.git = {
enable = true;
userName = "Simon Bruder";
userEmail = "simon@sbruder.de";
signing = {
key = config.programs.gpg.settings.default-key;
signByDefault = true;
};
extraConfig = {
core.quotepath = "off";
pull.ff = "only";
};
ignores = [
"*.swp"
".direnv"
"Session.vim"
];
lfs.enable = true;
delta = {
enable = true;
options = {
line-numbers = "true";
side-by-side = "true";
features = "decorations";
syntax-theme = "base16";
decorations = {
commit-decoration-style = "bold yellow box ul";
file-style = "bold yellow ul";
file-decoration-style = "none";
};
};
};
};
}