nixos-config/users/simon/modules/zsh.nix

72 lines
1.9 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

{ lib, pkgs, ... }:
let
dircolors-solarized = pkgs.fetchFromGitHub {
owner = "seebi";
repo = "dircolors-solarized";
rev = "65d4d595ceca96166139862131a006fa3079e00a";
sha256 = "1nl5rs24gi7zqg7nqsbf9fa94yggwzqf3n3imxgfywl8jny3cj1q";
meta.license = lib.licenses.mit;
};
in
{
programs = {
fzf.enable = true;
direnv = {
enable = true;
enableNixDirenvIntegration = true;
};
starship = {
enable = true;
settings = {
add_newline = false;
};
};
zsh = {
enable = true;
plugins = [
{
name = "zsh-nix-shell";
file = "nix-shell.plugin.zsh";
src = "${pkgs.zsh-nix-shell}/share/zsh-nix-shell";
}
];
shellAliases = {
exa = "exa --git --binary";
ipy = "ipython3";
l = "exa -l";
la = "exa -la";
ll = "exa -l";
ls = "exa";
userctl = "systemctl --user";
vim = "nvim";
vimdiff = "nvim -d";
ip = "ip --color=auto";
};
envExtra = ''
export _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=on"
'';
initExtra = ''
eval $(${pkgs.coreutils}/bin/dircolors -b ${dircolors-solarized}/dircolors.ansi-universal)
# no sad smiley (starship shows exit status)
zstyle ':prompt:grml:right:setup' items
# grml config sets these but systemd --user import-environment doesnt
# like escape sequences in environment variables
# FIXME: remove with systemd 248 (https://github.com/systemd/systemd/commit/30927a24848c4d727f7619cc74b878f098cdd724)
unset \
LESS_TERMCAP_mb \
LESS_TERMCAP_md \
LESS_TERMCAP_me \
LESS_TERMCAP_se \
LESS_TERMCAP_so \
LESS_TERMCAP_ue \
LESS_TERMCAP_us
source ${../files/zsh/pass-wrappers.zsh}
'';
};
};
}