nixos-config/modules/syncthing.nix

30 lines
721 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

# SPDX-FileCopyrightText: 2022-2023 Simon Bruder <simon@sbruder.de>
#
# SPDX-License-Identifier: AGPL-3.0-or-later
{ config, lib, ... }:
{
services.syncthing = {
enable = lib.mkDefault config.sbruder.gui.enable;
guiAddress = "${config.sbruder.wireguard.home.address}:8384";
openDefaultPorts = true;
user = "simon";
dataDir = "/home/simon";
overrideDevices = false;
settings = {
devices = {
fuuko = {
id = "Z2OO5LK-N3UVCRD-QKVKLZ3-3LRXUOH-JENBAKQ-M647E3L-7FL6LIE-74GGHQF";
};
};
};
overrideFolders = false;
# folders are not managed statically, because the list of devices cant be
# easily generated from the configuration
};
}