nixos-config/users/simon/modules/pass.nix

23 lines
448 B
Nix

# SPDX-FileCopyrightText: 2020 Simon Bruder <simon@sbruder.de>
#
# SPDX-License-Identifier: AGPL-3.0-or-later
{ pkgs, ... }:
{
programs.password-store = {
enable = true;
package = pkgs.pass-wayland.withExtensions (es: with es; [
pass-otp
pass-update
]);
settings = {
PASSWORD_STORE_DIR = "$HOME/.password-store";
};
};
programs.browserpass = {
enable = true;
browsers = [ "librewolf" ];
};
}