This repository has been archived on 2024-01-28. You can view files and clone it, but cannot push or open issues/pull-requests.
vs-overlay-jobset/release.nix

31 lines
759 B
Nix

{ nixpkgs, vs-overlay, supportedSystems, allowUnfree ? true }:
let
lib = import "${nixpkgs}/lib";
forAllSystems = lib.genAttrs supportedSystems;
in
forAllSystems (system:
let
pkgs = import nixpkgs {
inherit system;
overlays = [ (import vs-overlay) ];
config = {
inherit allowUnfree;
};
};
allPackages = pkgs.lib.filterAttrsRecursive
(k: v: k != "recurseForDerivations")
{
inherit (pkgs)
getnative
vapoursynthPlugins;
};
allPlugins = pkgs.lib.attrValues allPackages.vapoursynthPlugins;
in
allPackages // {
vapoursynthWithPlugins = pkgs.vapoursynth.withPlugins allPlugins;
vseditWithPlugins = pkgs.vapoursynth-editor.withPlugins allPlugins;
})