mirror of
https://github.com/tadeokondrak/vs-overlay
synced 2024-11-14 13:12:25 +01:00
Simon Bruder
3ac96a0fb0
This is done to mirror what is done in nixpkgs (https://github.com/NixOS/nixpkgs/pull/170414).
29 lines
810 B
Nix
29 lines
810 B
Nix
{ lib, stdenv, fetchFromGitHub, which, vapoursynth }:
|
|
|
|
stdenv.mkDerivation rec {
|
|
pname = "vapoursynth-bilateral";
|
|
version = "3";
|
|
|
|
src = fetchFromGitHub {
|
|
owner = "HomeOfVapourSynthEvolution";
|
|
repo = "VapourSynth-Bilateral";
|
|
rev = "r${version}";
|
|
sha256 = "05rhbg84z74rk3jcxa6abgqcqnjzgmjw03wljxa55jc358h9a6f0";
|
|
};
|
|
|
|
preConfigure = "chmod +x configure";
|
|
dontAddPrefix = true;
|
|
configureFlags = [ "--install=$(out)/lib/vapoursynth" ];
|
|
|
|
nativeBuildInputs = [ which ];
|
|
buildInputs = [ vapoursynth ];
|
|
|
|
meta = with lib; {
|
|
description = "Bilateral filter for VapourSynth";
|
|
homepage = "https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Bilateral";
|
|
license = licenses.gpl3;
|
|
maintainers = with maintainers; [ tadeokondrak ];
|
|
platforms = platforms.all;
|
|
};
|
|
}
|