vs-overlay/plugins/muvsfunc/default.nix
Simon Bruder eeceb7e2e4 vapoursynthPlugins: allow override of python version
When overriding the python3 dependency of vapoursynth, it should get
propagated to all plugins. Currently, however, this causes
incompatibilities, because `vapoursynth.python3.callPackage` only sets
the `python` attribute, not `python3`. This currently causes build
failures due to different site-packages paths.
2022-05-27 22:27:20 +02:00

50 lines
1.2 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ lib, vapoursynthPlugins, buildPythonPackage, fetchFromGitHub, matplotlib, python, vapoursynth }:
let
propagatedBinaryPlugins = with vapoursynthPlugins; [
descale
histogram
median
tcanny
];
in
buildPythonPackage rec {
pname = "muvsfunc";
version = "unstable-2020-09-09";
src = fetchFromGitHub {
owner = "WolframRhodium";
repo = pname;
rev = "5b5f245f090b6a4de7910ae6168b3ef0e28d2c70";
sha256 = "1yyqdmlsvz5p07bvfkf48mggz6cdk199ai2pr2apvgcr2pchxc90";
};
propagatedBuildInputs = [
matplotlib
] ++ (with vapoursynthPlugins; [
havsfunc
mt_lutspa
mvsfunc
nnedi3_resample
]) ++ propagatedBinaryPlugins;
format = "other";
installPhase = ''
install -D muvsfunc.py $out/${python.sitePackages}/muvsfunc.py
'';
checkInputs = [ (vapoursynth.withPlugins propagatedBinaryPlugins) ];
checkPhase = ''
PYTHONPATH=$out/${python.sitePackages}:$PYTHONPATH
'';
pythonImportsCheck = [ "muvsfunc" ];
meta = with lib; {
description = "Muoniums VapourSynth functions";
homepage = "https://github.com/WolframRhodium/muvsfunc";
license = licenses.unfree; # no license
maintainers = with maintainers; [ sbruder ];
platforms = platforms.all;
};
}