vs-overlay/plugins/cas/default.nix

30 lines
840 B
Nix

{ lib, stdenv, fetchFromGitHub, meson, ninja, pkg-config, vapoursynth }:
stdenv.mkDerivation rec {
pname = "VapourSynth-CAS";
version = "2";
src = fetchFromGitHub {
owner = "HomeOfVapourSynthEvolution";
repo = pname;
rev = "r${version}";
sha256 = "0zcqz6vgfqy4lshc0cvf8hijs2y7c4nvm5nzmb8fl8si38d96rf5";
};
nativeBuildInputs = [ meson ninja pkg-config ];
buildInputs = [ vapoursynth ];
postPatch = ''
substituteInPlace meson.build \
--replace "vapoursynth_dep.get_pkgconfig_variable('libdir')" "get_option('libdir')"
'';
meta = with lib; {
description = "CAS filter plugin for VapourSynth";
homepage = "https://github.com/HomeOfVapourSynthEvolution/VapourSynth-CAS";
license = licenses.mit;
maintainers = with maintainers; [ sbruder ];
platforms = platforms.all;
};
}