vs-overlay/plugins/combmask/default.nix

45 lines
1.0 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

{ lib, stdenv, fetchFromGitHub, pkg-config, which, vapoursynth }:
stdenv.mkDerivation rec {
pname = "CombMask";
version = "1.1.0";
src = fetchFromGitHub {
owner = "chikuzen";
repo = pname;
rev = version;
sha256 = "04axqp44w7vqrc6lr88j7j1xvj18sbx6fyyqjkqlcvqnn0kg4ksn";
};
postPatch = ''
# headers are provided by nixpkgs vapoursynth
rm vapoursynth/src/VapourSynth.h
'';
preConfigure = ''
cd vapoursynth/src
'';
configurePhase = ''
runHook preConfigure
bash configure \
--extra-cflags="$(pkg-config --cflags vapoursynth)" \
--cc="$CC" \
--install="$out/lib/vapoursynth"
runHook postConfigure
'';
nativeBuildInputs = [ pkg-config which ];
buildInputs = [ vapoursynth ];
meta = with lib; {
description = "A comb mask create filter for VapourSynth";
homepage = "https://github.com/chikuzen/CombMask";
license = licenses.lgpl21Plus;
maintainers = with maintainers; [ sbruder ];
platforms = platforms.all;
};
}