vs-overlay/plugins/deblock/default.nix

30 lines
862 B
Nix

{ lib, stdenv, fetchFromGitHub, meson, ninja, pkg-config, vapoursynth }:
stdenv.mkDerivation rec {
pname = "VapourSynth-Deblock";
version = "6.1";
src = fetchFromGitHub {
owner = "HomeOfVapourSynthEvolution";
repo = pname;
rev = "r${version}";
sha256 = "0s2aqfak8mxylkhfl350mm8abspp7sgfacnigf7qksvhdx232k2c";
};
nativeBuildInputs = [ meson ninja pkg-config ];
buildInputs = [ vapoursynth ];
postPatch = ''
substituteInPlace meson.build \
--replace "vapoursynth_dep.get_pkgconfig_variable('libdir')" "get_option('libdir')"
'';
meta = with lib; {
description = "A Deblock filter plugin for VapourSynth.";
homepage = "https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Deblock";
license = licenses.gpl2Plus;
maintainers = with maintainers; [ sbruder ];
platforms = platforms.all;
};
}