vs-overlay/plugins/descale/default.nix

35 lines
1.0 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

{ lib, stdenv, fetchFromGitHub, meson, ninja, pkg-config, vapoursynth, python }:
# required to make python.buildEnv use descales python module
python.pkgs.toPythonModule (stdenv.mkDerivation rec {
pname = "vapoursynth-descale";
version = "6";
src = fetchFromGitHub {
owner = "Irrational-Encoding-Wizardry";
repo = pname;
rev = "r${version}";
sha256 = "093dk125y4gacvhrh10x1i5g2qbsjl4spz74gjjm7xbvrvi1sc72";
};
nativeBuildInputs = [ meson ninja pkg-config ];
buildInputs = [ vapoursynth ];
postPatch = ''
substituteInPlace meson.build \
--replace "vs.get_pkgconfig_variable('libdir')" "get_option('libdir')"
'';
postInstall = ''
install -D ../descale.py $out/${python.sitePackages}/descale.py
'';
meta = with lib; {
description = "VapourSynth plugin to undo upscaling";
homepage = "https://github.com/Irrational-Encoding-Wizardry/vapoursynth-descale";
license = licenses.wtfpl;
maintainers = with maintainers; [ sbruder tadeokondrak ];
platforms = platforms.all;
};
})