vs-overlay/plugins/mvsfunc/default.nix

39 lines
999 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

{ lib, buildPythonPackage, fetchFromGitHub, vapoursynthPlugins, python, vapoursynth }:
buildPythonPackage rec {
pname = "mvsfunc";
version = "10";
src = fetchFromGitHub {
owner = "HomeOfVapourSynthEvolution";
repo = pname;
rev = "r${version}";
sha256 = "sha256-J68NMBE3MdAd9P0UJH32o0YwQx+7I5+13j8Jc5rbQtc=";
};
propagatedBuildInputs = with vapoursynthPlugins; [
bm3d
fmtconv
];
format = "other";
installPhase = ''
install -D mvsfunc.py $out/${python.sitePackages}/mvsfunc.py
'';
checkInputs = [ (vapoursynth.withPlugins propagatedBuildInputs) ];
checkPhase = ''
PYTHONPATH=$out/${python.sitePackages}:$PYTHONPATH
'';
pythonImportsCheck = [ "mvsfunc" ];
meta = with lib; {
description = "mawen1250s VapourSynth functions";
homepage = "https://github.com/HomeOfVapourSynthEvolution/mvsfunc";
license = licenses.unfree; # no license
maintainers = with maintainers; [ sbruder ];
platforms = platforms.all;
};
}